Laravel 10 - laravel/framework[v10.0.0] require composer-runtime-api ^2.2 - Solved

By Hardik Savani November 5, 2023 Category : Laravel

Yesterday i was trying to download laravel 10 project using composer command i found following error:


Problem 1

- laravel/framework [v10.0.0, ..., v10.0.3] require composer-runtime-api ^2.2 -> found composer-runtime-api[2.1.0] but it does not match the constraint.

- Root composer.json requires laravel/framework ^10.0 -> satisfiable by laravel/framework [v10.0.0, v10.0.1, v10.0.2, v10.0.3].


Then i research and found that i had old composer version and i need to update it using the below command:

If you have same problem then you need to run following two commands and fix the problem:


composer clearcache

composer selfupdate

I hope it can help you...